1
Vote

Installed extension v 1.2 on DNN 8.0.3 & nothing added to Site Settings!

description

I'm running DNN 8.0.3 at Managed and just installed
DNN Url Redirect Provider (Version 01.02.00)
It reported a successful install.

But nothing new shows up under Admin | Site Settings. (Certainly not a new tab, which I think is what I should be looking for?) Do I have to 'add' the module to a page on the site, or ???

From Host SQL page I can run:
Select * from dbo.ExtensionUrlProviders

and it looks good:

file attachments

comments

JohnPlex wrote Oct 25, 2016 at 7:16 PM

Here's the reply from the sql query...

I've forced refresh of the page, but not restarted the site yet.

JohnPlex wrote Oct 25, 2016 at 8:37 PM

Yeah, it now is working!

I had forced a page rewrite, and I thought uploading a new web.config would have forced a reset of everything anyway, but anyway it now looks fine.

Also the Advanced URL Settings is now showing up in Site Settings as a new tab.

Sorry for the alarm. Maybe make a note to restart the IIS site in the documentation?

JohnPlex wrote Oct 25, 2016 at 8:50 PM

Ah, other things that also happened (and may need documenting?):
  • Recycle App pool in IIS
  • Change web.config's DNNFriendlyURL setting from urlFormat="HumanFriendly" to urlFormat="Advanced"
(I was not trying to do anything fancy, just get rid of the *.aspx extensions that had been necessary on my pages up until today. Maybe I didn't even need to install your module?!!! If so, I wish that had been documented somewhere!!)

Anyway, this issue can be closed.